Scheduled for August 14, 2024 at 1:00 PM – 3:00 PM
Affects
Partner Portal
Under maintenance from 1:00 PM to 3:00 PM
Completed
August 14, 2024 at 3:00 PMCompleted
August 14, 2024 at 3:00 PMMaintenance has completed successfully.
In progress
August 14, 2024 at 1:00 PMIn progress
August 14, 2024 at 1:00 PMWe are currently migrating users over to our new partner portal. There may be a brief outage due to DNS. Some users may need to reset their passwords.